Tuesday, April 22, 2014

T3-9670 9600 baud data radio


Available in two versions from Argent Data
* Data Radio
* Data Radio tracker with GPS

Notes:
* Relevant Options
- TXFREQ Default=430.xxx Ours=440.800
- RXFREQ Default=430.xxx Ours=440.800
- TXPOWER Percentage Default=100 Ours=10
- USBKISS ON # for KISS mode. Non-standard 3x control-C to exit KISS mode.
# to ping network, change UNPROTO and CONV to send out packets. control-C to exit Convers mode.
- UNPROTO APX200 VIA WIDE2-2 with PATH WIDE2-2.
* Scott: The TOCALL field can't be changed - it's fixed at APOTxx.
* Scott: HBAUD is ignored for now. When I've had more time to test it, it'll support other FSK baud rates, but it won't do 300 or 1200 baud AFSK.

Scott

On Linux:
Plug in
'dmesg' command to see the USB port associated. Mine was /tty/devASM0 ??

On Windows:
Plug in
Find Unknown USB Device
Update software with .INF file from Argent. Full instructions at:
I had to update twice. The first time it wouldn't start.

Wishlist and tweaks:
* Adjustable faster HBAUD speeds
* Change the TOCALL field
* Remove the software carrier detect switch. It probably doesn't apply.

Friday, April 18, 2014

HPRAN - High Performance Radio Area Network


A local, experimental, high performance and robust data backbone.

Goals
* greater than 100 Mb/s performance.
* robust loss of any one node will on
* optional and controllable - passing OLSRD mesh routing info transparently. Learn how to do this.

Measuring
* network monitoring such as MRTG or CACTI
* examples -

Technologies
* Mikrotik radios, 5 GHz, NV2 data
* N or AC mode for user access - ideally both 2.4 and 5 GHz.

Equipment Acquired or otherwise allocated to project
* x/x/2014 - 14xNn $80 Mikrotik Groove from XX
* x/x/2014 - 14xNn $95 Mikrotik 5SHPn 14xNN1 from XX
* 4/18/2014 - 14d41 $46 ECHO58 Echo Series 5.3GHz - 5.8GHz 17 dBi Backfire Antenna from FAB Corp
* 4/14/2014 - 14d42 $54 patch58-19 Tri-Band 5.3GHz - 5.8GHz 19dBi Flat Panel Antenna from FAB Corp

Notes
* Complete system will have two full service nodes each linked to two Link nodes
* The services and data on each of the servers will be identica.
* A third server will be running 'at home' to provide hot backup and development
* Full Service Node - all provide the same services with mirrored data
* Running on UPS
* Full size external hard disk of at least 1T
* User Access
* Two Backbone Radios
* Server -
* IRC
* Asterix
* Link Node
* User Access - one switch with gigabit Ethernet and dual radios on 2.4 GHz and 5 GHz
* Two backbone radios
* DC power - probably 12V

Mikrotik Notes

Q: Dean - If you add lines to a list (say, the "/ip firewall filter" list), they are added at the end.  Then, you can "print" where they are in the list, and "move" them to where you want them.  You can't directly insert, but that's OK.   Where the idiosyncrasy comes is, if you save what you did, and later paste it into the command line (without including the "print" command), it won't work.  Apparently the numbering of the lines (needed for the "move" command) doesn't occur until you do a "print".

A: Nigel - You can indeed place them where you like, using 'place-before=NUM' in your add command, and yes, numbering is dependent on you having performed a

HamWAN Notes

Tom/LXL - With the SNMP stuff I've been playing with for MRTG/Cacti - it's just a read only port. If so, maybe Dean would open that up for you.
It should be enough to complete the snmp section of the client node configuration instructions:
/snmp set enabled=yes contact="#HamWAN on irc.freenode.org"
/snmp community set name=hamwan addresses=44.24.255.0/25 read-access=yes write-access=no numbers=0

Wednesday, April 16, 2014

Conversd Server


Another project one of these months...



This is the system (IRC clone sorta) I was talking about.

http://mysite.verizon.net/ka1fsb/convers.html

http://www.linux-ax25.org/wiki/Ping-Pong_Convers_Server_software

JNOS has a server built in but the real answer (besides IRC) is Linux.

Mobile/Portable Async Data Exchange


Some notes on another project in the contemplation phase...


Email, files, Newsgroup discussions (NNTP)


The DTN project is interesting - but does it help with the drive-by Wifi scheme? Here the motorcycle network story that originally gave me the idea:

http://www.nytimes.com/2004/01/26/technology/26oxcart.html

I probably should dig a little deeper and see if more technical details are available.

http://www.firstmilesolutions.com/

Also

http://www.scidev.net/global/digital-divide/feature/rural-internet-not-online-but-still-connected.html

RPI MESH Gateway (14.142)


The latest Raspberry PI was picked up from Zeus this morning. Now to get a memory chip this afternoon and power it up tonight. This system is going for a FAST memory instead of a big memory. Between using /tmpfs RAM drive for the really fast needs and a thumb drive for caching content I should be able to minimize use of the SD card.

Basic functionality

This server will connect to a source of Internet access - either as a WiFi Client or by wired 10/100/1000 Ethernet. This Internet service will be 'managed' and then made available to the to a NW-MESH system.

* Netgear 2000 XZY network extender for the preliminary WIFI client access. (May need a different device in the future that allows replacing the antenna.)
* Raspberry PI for network caching and filtering services. Also some minimal standalone services can be hosted.
* WRT54G NW-MESH box to connect to the PI and provide mesh access
* (optional) another Access Point on the mesh to allow for local Wireless user access.
* Filtered Power strip - UPS? - 12V battery?
* Box - tool box or battery box - to make everything transportable.

Specific Goals so far:

* Caching DNS
* Squid for Web caching
* Fail2ban for secure web access
* denyhosts
* Block ad sources (URL goes here)
* ntpd time server - as long as it's on the web which is the purpose of this device.

Common services and applications installed

* screen
* htop
* email - it's on the web so use it
* snmp

Optional

* lighttpd and php
* mrtg

TODO Next

* Program memory. Boot up. Enable SSH. Set Host Name. Set Keyboard to English. Update and upgrade OS. Install common services and applications. Write a blog page for a basic RPI setup.

Log

4/15/4014 - Purchased an 16 GB Ultra SDHC SanDisk memory card from the local RS for $16.41. Price does down every time I get one. Listed speed is up to 30 MB/s - we shall see..

Tuesday, April 15, 2014

MESH-PI (HSMM-PI)


I wasn't going to do this now but with the need for the old-house-cam and the potential that it would fit right in, that was all the excuse I needed. I think the final nudge was the easy of getting MRTG running on a RPI so I could track the mesh traffic like I've been tracking local 9600 Packet.

Goal: Get NW-MESH running on a RPI so I can access the old house cam from the web.

Here's the project home pages are at wordpress HSMM-PI and GITHUB HSMM-PI for discussion there is aGoogle + Community


TODO Next:

Reload PI SD card with last summers Image. Don't update it. Try installing version 2.0 of HSMM-PI with the update disabled. Theory has it that this will work with the boguss WIFI card.

Reload PI SD card with the latest RPI image. Update it. Fire up the AE2500 dual band dongle. Install version 3.0 of HSMM-PI.

TODO Someday:

Learned:

Had to make /root chmod 777 instead of the 440 it was set in the script - Yes I know, that's not secure. Fix it someday will I.

Issue 2

Edimax WIFI card won't work.


LOG:

3/27/2014 - Learned from Rusty that my RF WIFI was most likely at fault.

3/26 - postings on last nights efforts.

Rusty: Bill, despite there being 32 ASCII characters in the old HSMM-Mesh key file, '/etc/olsrd.key' (well, current one too), only the first 16-characters are read (or have ever been read)

Bill: I can confirm that only the first 16 characters are needed for the key. Didn't help with MESH on the RPI so I'm backing up and going to try a different radio (AE2500) with it.

Rusty: You weren't using an Edimax or one of the other 2-3 dozen of the RealTek RTL8192CU chipsets in it, were you? If so, and using one of the last two releases of Raspbian, I can assure you it won't work. The Secure Plugin key has nothing to do with it.

Bill: Bingo... Exactly as I discovered. "Dongle is Edimax EW-7811Un 150 Mbps Wireless 11n Nano" Will try the Cisco AE2500 tonight and order something supported later if that doesn't work.

Rusty: I went back to the Sept '12 release of Raspbian and disabled the 'apt-get upgrade' in HSMM-Pi's 'install.sh' script. Worked just fine with the Edimax.

Bill: Good idea - Thanks! I have a RPI install image from last July I could take for a test drive. Should work as long as I'm careful with the 'upgrade' calls. Would love to have this running for the MicroHams show on Saturday - specially if I can get SNMP/MRTG showing the network traffic like I do on 9600 packet.

Rusty: I do know that at least most anything with an Atheros chipset works with the latest Raspian. I'm currently using a TP-Link TL WN721N with the latest release. The 722 has a detachable antenna, I believe.
...

Thursday, April 3, 2014

MRTG on the web


Done:

Running on JNOS

Running on the WRT54GS

Running on the Raspberry PI


To Do:

Learn how to run SNMP on the WRT54G's with only 4 MB flash. That will probably be a matter of learning which packages are installed and how to install them individually instead of downloading the 100K list of packages.

Learn how to install and run SNMP on the Bullet running OpenWRT/NW-MESH software.